PostgreSQL 9.2 and 9.3 Now Available on Travis CI!

Mathias Meyer,

PostgreSQL is a fast-moving database beast. We're big fans and very happy users of it ourselves, with Travis CI running on a total of eight database servers.

For the longest time, all we had to offer to our users and customers was the standard 9.1 distribution that comes with Ubuntu 12.04. But since then, PostgreSQL has moved on, bringing more and more feature goodies with every release.

Release 9.2 brought the new JSON data type and support to fetch data directly from indexes (very relevant to us too), and 9.3 brought materialized views, even more goodness for JSON data types and greatly improved shared memory requirements along the way.

Being able to test against newer versions of PostgreSQL then, was long overdue!

Today we're happy to ship support for three different versions, 9.1, 9.2 and 9.3, all pulled directly from PostgreSQL's APT repository. All come with PostGIS 2.1 preinstalled and enabled!

How can you start testing against different PostgreSQL versions on Travis CI?

We added a new addon for this. To test your project against 9.3, add this to your .travis.yml

addons:
  postgresql: 9.3

You can pick one of 9.1, 9.2 or 9.3 as a version number. The right version will already be up and running when your test run starts!

A big thank you to Gilles Cornu for the hard work he's put into this feature!

PostgreSQL 9.2 and 9.3 are available for open source and private repositories today!

Want to be notified about new articles and updates? Sign up for our newsletter, we'll send you coffee tips as well!

blog comments powered by Disqus